Opened 6 years ago

Closed 6 years ago

#504 closed Bug / Defect (duplicate)

Routing table change should either be complete, or not change at all

Reported by: yurivict Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: OpenVPN 2.2.2 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

I spotted the situation when 'openvpn xxx.ovpn' failed to add the routing rule to route to the VPN server IP through the previously default interface, therefore leaving VPN non-functional.

OpenVPN code should always keep the change "atomic", it is either complete, or rolled back.

This problem may appear as an intermittent failure to the user.

OS: FreeBSD 10.1

Change History (3)

comment:1 Changed 6 years ago by Gert Döring

Indeed. Do you have any idea why the installation of the new route failed, or happen to have a log file demonstrating the issue?

comment:2 Changed 6 years ago by yurivict

Sorry, I recently filed another bug about the similar situation.
No, I can't provide the log for this one now.
I filed this for the record that this is possible, route(8) command can fail any time for any reason. Rollback procedure should be clean.
You can just simulate the failure by adding something like this: if (random%3==0) fail(), and you will most likely see that shutdown isn't clean.

Last edited 6 years ago by yurivict (previous) (diff)

comment:3 Changed 6 years ago by Gert Döring

Resolution: duplicate
Status: newclosed

Ah, so this is a duplicate of #544.

Will close this one, look into the other one.

Note: See TracTickets for help on using tickets.