Opened 4 years ago

Last modified 4 years ago

#496 accepted Bug / Defect

src/plugins/down-root/down-root.c should use src/compat/compat-daemon.c when daemon() not exist

Reported by: bluestonechina Owned by: Gert Döring
Priority: minor Milestone:
Component: plug-ins / plug-in API Version: OpenVPN git master branch (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: daemon()
Cc:

Description

when daemon() does not exist, down-root.c cannot use daemon() function from src/compat/compat-daemon.c.

This cause openvpn build faild on AIX.

Change History (3)

comment:1 Changed 4 years ago by Gert Döring

Owner: set to Gert Döring
Status: newaccepted

OK, I'll bite... I never tested the plugins on AIX, was happy enough that the rest worked.

Will see that I can get this worked in - you don't happen to have a patch ready so I just need to review and merge?

comment:2 Changed 4 years ago by Gert Döring

I tried building on AIX without --disable-plugins, and I can't even link anything

/bin/sh ../../../libtool --mode=link --tag=CC gcc -I../../../../git/include -I/gnu/openssl/include -g -O2 -o openvpn-plugin-auth-pam.la -rpath /usr/local/lib/openvpn/plugins -export-symbols "../../../../git/src/plugins/auth-pam/auth-pam.exports" -module -shared -avoid-version -no-undefined auth-pam.lo pamdl.lo -lpam
libtool: link: can not build a shared library
libtool: link: See the libtool documentation for more information.
libtool: link: Fatal configuration error.

so... what exactly did you do to get to the point of not having daemon()?

comment:3 Changed 4 years ago by Gert Döring

Hrmph, posted a longer answer, trac ate it... I'm not sure I'm properly reproducing it - I can link by using libtool-2.4.6, but I can not see an error.

Could you please explain in more detail what you do, and where you see the error? Is this a build error, or when trying to run openvpn?

Note: See TracTickets for help on using tickets.