Opened 6 years ago

Closed 5 years ago

#430 closed Bug / Defect (fixed)

tap-windows6: creating new TAP interface while an existing is connected causes error loop

Reported by: dgollub Owned by: jamesyonan
Priority: major Milestone:
Component: tap-windows6 Version: OpenVPN git master branch (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc: Gert Döring

Description

tap-windows6 Git master is used (g3b47498). Not a community installer build.

Steps to reproduce:

  1. create first TAP instance with devcon.exe install tap...inf tap....
  2. connect with OpenVPN daemon (or OpenVPN-GUI) to an OpenVPN server instance
  3. while connected create another TAP interface instance: devcon install tap...inf tap....

Expected result:

Ideally the existing connection should stay alive - but this is not the scope of the bug. (This would be more a feature request - if this is technical possible at all)

No error message infinite loop of the OpenVPN daemon/client.

Actual result:

[...]
Wed Jul 16 15:18:02 2014 Successful ARP Flush on interface [41] {8FA2E951-7107-43E4-9244-3664AA345119}
Wed Jul 16 15:18:07 2014 Initialization Sequence Completed
Wed Jul 16 15:20:34 2014 read from TUN/TAP : The I/O operation has been aborted because of either a thread exit or an application request.   (code=995)
Wed Jul 16 15:20:34 2014 read from TUN/TAP : The I/O operation has been aborted because of either a thread exit or an application request.   (code=995)
Wed Jul 16 15:20:34 2014 read from TUN/TAP : The I/O operation has been aborted because of either a thread exit or an application request.   (code=995)
Wed Jul 16 15:20:34 2014 read from TUN/TAP : The I/O operation has been aborted because of either a thread exit or an application request.   (code=995)
Wed Jul 16 15:20:34 2014 read from TUN/TAP : The I/O operation has been aborted because of either a thread exit or an application request.   (code=995)
Wed Jul 16 15:20:34 2014 read from TUN/TAP : The I/O operation has been aborted because of either a thread exit or an application request.   (code=995)
....

With tap-windows (NDIS5) and the same OpenVPN daemon/client this error at least appears only once and the OpenVPN client terminates gracefully.

The error flooding is even making the OpenVPN-GUI nearly unresponsive slow.

Change History (18)

comment:1 Changed 6 years ago by dgollub

comment:2 Changed 6 years ago by Samuli Seppänen

Component: tap-windowstap-windows6
Owner: set to jamesyonan
Status: newassigned

comment:3 Changed 6 years ago by Samuli Seppänen

comment:4 in reply to:  3 Changed 6 years ago by ssamppa

Replying to samuli:

Have you tried reproducing this problem using the official OpenVPN installers? For example these:

I am using the official installer on Windows 8 and on Windows 7 and both have suffered this issue.
On both log file was tens of gigabytes full of that error message.

Version in use: OpenVPN 2.3.4 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Aug 7 2014

comment:5 Changed 6 years ago by Samuli Seppänen

The developer of tap-windows6 is looking into this issue.

comment:6 Changed 6 years ago by izstas

I am having a similar issue:

I am using official installer openvpn-install-2.3.4-I603-x86_64 on Windows 8.1 on a laptop. If OpenVPN is running and connected, and then laptop goes into hibernation, after resuming I see the same log flood as provided in the ticket, and connection stays down.

comment:7 Changed 6 years ago by matthew.laney

I am also using the official installer of 2.3.4 on Windows 8. It's generating this error thousands of times per second and created a 75GB log filing up the SSD on my laptop.

comment:8 Changed 6 years ago by JWA

I am using the official installer for 2.3.4 on Windows 7, and getting the same looping issue. It occurs with no connections. I can reproduce it consistently by starting the OpenVPN service, putting the server into Sleep mode, and as soon as I wake it up, I look at the server log and it is going crazy with this error. I stop the service and the error stops. This did not occur in version 2.1.3.

In my current setup I renamed the TAP adapter to a custom name. It is set to Always Connected under media status in the device manager properties. Ethernet card is set to enable WOL.

comment:9 Changed 6 years ago by fly4theking

Same issue here. Doesn't happen when not run as service.

comment:10 Changed 6 years ago by Samuli Seppänen

Can you try out if these installers/executables fix this issue?

comment:11 Changed 6 years ago by izstas

For me, this seems to stop the log spam, however VPN connection is not getting restored when the computer wakes up. The log ends with:

Mon Oct 06 13:59:25 2014 TUN/TAP I/O operation aborted, exiting
Mon Oct 06 13:59:25 2014 Exiting due to fatal error
Mon Oct 06 13:59:25 2014 C:\Windows\system32\route.exe DELETE 0.0.0.0 MASK 0.0.0.0 192.168.255.1
Mon Oct 06 13:59:25 2014 Warning: route gateway is not reachable on any active network adapters: 192.168.255.1
Mon Oct 06 13:59:25 2014 Route deletion via IPAPI failed [adaptive]
Mon Oct 06 13:59:25 2014 Route deletion fallback to route.exe
Mon Oct 06 13:59:25 2014 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Mon Oct 06 13:59:25 2014 C:\Windows\system32\route.exe DELETE 192.168.1.0 MASK 255.255.255.0 192.168.255.1
Mon Oct 06 13:59:25 2014 Warning: route gateway is not reachable on any active network adapters: 192.168.255.1
Mon Oct 06 13:59:25 2014 Route deletion via IPAPI failed [adaptive]
Mon Oct 06 13:59:25 2014 Route deletion fallback to route.exe
Mon Oct 06 13:59:25 2014 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Mon Oct 06 13:59:25 2014 Closing TUN/TAP interface

comment:12 Changed 6 years ago by statia

I installed and config'd OpenVPN (server) yesterday on my Win 2012 server. Everything running fine. I put the server to sleep during the night and wake up in the morning. This morning I could establish a VPN connection ok from client, but could not connect to anything on the network, nor get a ping response remotely. The server.log file was over 110Gb in size and was full of the following errors:

The I/O operation has been aborted because of either a thread exit or an application request. (code=995)

I have installed the executable you referenced to see if this fixes the issue.

I had to delete the log file as I was rapidly running out of available space on the drive.

comment:13 Changed 6 years ago by Samuli Seppänen

Statia: the return code 995 from tap-windowss6 is handled by OpenVPN in the above installers, which seemed to have fixed this issue for izstas. Are you 100% sure that you're not using old (unfixed) OpenVPN binaries by mistake?

comment:14 Changed 6 years ago by Gert Döring

Cc: Gert Döring added

comment:15 Changed 6 years ago by xOOn

Hello I have the same problem on multiple PC's the TAP Adapter with version 9.0.0.9 is working when I update to 9.0.0.21 than this problem occurs.

With installer posted above the error messages disappears but the client is not reconnecting...

comment:16 Changed 6 years ago by Samuli Seppänen

Can you try the latest Windows installers (2.3.5-I602)? There are several tap-windows6 fixes in that release.

comment:17 Changed 6 years ago by xOOn

Hello,

the problem seems to be fixed in version 2.3.5.

Thanks

comment:18 Changed 5 years ago by Samuli Seppänen

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.