Opened 4 years ago

Closed 9 months ago

#43 closed Bug / Defect (worksforme)

BSOD on hibernate in Windows Vista

Reported by: samuli Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: 2.1.0 / 2.1.1
Severity: Not set (if unsure, select this one) Keywords: bsod windows suspend hibernate tap tap-windows
Cc:

Description

OpenVPN seems to cause BSOD in Windows Vista during hibernation. More details scraped from two SF.net tickets in comments section.

Change History (4)

comment:1 Changed 4 years ago by samuli

This problem was reported to SF.net by szalicil (http://sourceforge.net/users/szalicil):

os: vista 32bit
openvpn: 2.1rc20

"DRIVER_POWER_STATE_FAILURE"
BugcheckCode 159
BugcheckParameter 0x3
BugcheckParameter 0x8494df00
BugcheckParameter 0x86b70380
BugcheckParameter 0x85ef9d98 

It was also reported by somebody (anononymous) else:

My DELL D820 running Vista SP1 Build 6001 bluescreened on hibernate, OpenVPN GUI 1.0.3 and OpenVPN 2.1_rc15 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Nov 19 2008 was running and probably connected (but not sure). Windbg reports the following:

DRIVER_POWER_STATE_FAILURE (9f)
A driver is causing an inconsistent power state.
Arguments:
Arg1: 00000003, A device object has been blocking an Irp for too long a time
Arg2: 84b56da0, Physical Device Object of the stack
Arg3: 86b32030, Functional Device Object of the stack
Arg4: 85405b48, The blocked IRP

Debugging Details:
------------------


DRVPOWERSTATE_SUBCODE: 3

IRP_ADDRESS: 85405b48

DEVICE_OBJECT: 86b32030

DRIVER_OBJECT: 86bd43e8

IMAGE_NAME: tap0901.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 49245966

MODULE_NAME: tap0901

FAULTING_MODULE: 8f93f000 tap0901

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

BUGCHECK_STR: 0x9F

PROCESS_NAME: System

CURRENT_IRQL: 2

LAST_CONTROL_TRANSFER: from 82669b5c to 827030e3

STACK_TEXT:
8272bacc 82669b5c 0000009f 00000003 84b56da0 nt!KeBugCheckEx+0x1e
8272bb28 826696ac 8272bb94 8272bc50 82744401 nt!PopCheckIrpWatchdog+0x1ad
8272bb68 826ecc40 827444e0 00000000 a413a2d0 nt!PopCheckForIdleness+0x343
8272bc88 826ec800 8272bcd0 00000002 8272bcd8 nt!KiTimerListExpire+0x367
8272bce8 826ec3c3 00000000 00000000 01718a35 nt!KiTimerExpiration+0x22a
8272bd50 826eaedd 00000000 0000000e 00000000 nt!KiRetireDpcList+0xba
8272bd54 00000000 0000000e 00000000 00000000 nt!KiIdleLoop+0x49


STACK_COMMAND: kb

FOLLOWUP_NAME: MachineOwner

FAILURE_BUCKET_ID: 0x9F_IMAGE_tap0901.sys

BUCKET_ID: 0x9F_IMAGE_tap0901.sys

Followup: MachineOwner

This second report was commented twice by real_nowhereman (http://sourceforge.net/users/real_nowhereman):

Date: 2009-08-27 22:10:56 EEST
Sender: real_nowhereman

Confirming this bug on a Dell Studio 1537 and vista SP2

0: kd> !analyze -v
*******************************************************************************
*
*
* Bugcheck Analysis
*
*
*
*******************************************************************************

DRIVER_POWER_STATE_FAILURE (9f)
A driver is causing an inconsistent power state.
Arguments:
Arg1: 00000003, A device object has been blocking an Irp for too long a
time
Arg2: 8455ac70, Physical Device Object of the stack
Arg3: 85f93380, Functional Device Object of the stack
Arg4: 855cfd98, The blocked IRP

Debugging Details:
------------------


DRVPOWERSTATE_SUBCODE: 3

IRP_ADDRESS: 855cfd98

DEVICE_OBJECT: 85f93380

DRIVER_OBJECT: 860610f0

IMAGE_NAME: tap0901.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 48ec41da

MODULE_NAME: tap0901

FAULTING_MODULE: a15f7000 tap0901

CUSTOMER_CRASH_COUNT: 1

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

BUGCHECK_STR: 0x9F

PROCESS_NAME: System

CURRENT_IRQL: 2

LAST_CONTROL_TRANSFER: from 8203d3ab to 820d9b0d

STACK_TEXT:
82101acc 8203d3ab 0000009f 00000003 8455ac70 nt!KeBugCheckEx+0x1e
82101b28 8203cfc8 82101b94 82101c50 82106801 nt!PopCheckIrpWatchdog+0x1ad
82101b68 820b62eb 8211a4e0 00000000 bfdc6230 nt!PopCheckForIdleness+0x343
82101c88 820b5eab 82101cd0 8f002b02 82101cd8 nt!KiTimerListExpire+0x367
82101ce8 820b6615 00000000 00000000 02b199a6 nt!KiTimerExpiration+0x22a
82101d50 820b487d 00000000 0000000e 00000000 nt!KiRetireDpcList+0xba
82101d54 00000000 0000000e 00000000 00000000 nt!KiIdleLoop+0x49


STACK_COMMAND: kb

FOLLOWUP_NAME: MachineOwner

FAILURE_BUCKET_ID: 0x9F_IMAGE_tap0901.sys

BUCKET_ID: 0x9F_IMAGE_tap0901.sys

Followup: MachineOwner

---

Date: 2009-08-27 22:17:43 EEST
Sender: real_nowhereman
Hide

bug was with rc18, I didn't see rc19 is out and looks like it might
actually collaterally address the issue; I'll try and see if the problem
will come up again


comment:2 Changed 13 months ago by samuli

This bug report was filed against a very old OpenVPN version. Can somebody confirm that this is still an issue with latest OpenVPN versions?

comment:3 Changed 13 months ago by samuli

  • Keywords bsod windows suspend hibernate tap tap-windows added

comment:4 Changed 9 months ago by samuli

  • Resolution set to worksforme
  • Status changed from new to closed

Not confirmed on any recent openvpn versions. Closing, reopen if necessary.

Note: See TracTickets for help on using tickets.