Opened 5 years ago

Closed 15 months ago

#409 closed Bug / Defect (worksforme)

OpenVPN Connect not working for certain server configuration (Android and iOS)

Reported by: CypZ Owned by: Antonio
Priority: major Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Hello,

Since I think this is a bug in OpenVPN Connect, I publish here. I can't get my config to work with OpenVPN Connect (Android and iOS iPhone/iPad tested). OpenVPNGui for windows and some other OpenVPN Client on Android works well...

connect.ios 1.0.4-140
IV_VER=3.0
IV_PLAT=ios
IV_NCP=1


2014-05-02 15:55:01 TCP recv EOF
2014-05-02 15:55:01 Transport Error: Transport error on 'mydomain: NETWORK_EOF_ERROR
2014-05-02 15:55:01 Client terminated, restarting in 2...
2014-05-02 15:55:03 EVENT: RECONNECTING
2014-05-02 15:55:03 LZO-ASYM init swap=0 asym=0
2014-05-02 15:55:03 EVENT: RESOLVE
2014-05-02 15:55:03 Contacting myIP:1194 via TCP
2014-05-02 15:55:03 EVENT: WAIT
2014-05-02 15:55:03 Connecting to mydomain:1194 (myIP) via TCPv4
2014-05-02 15:55:03 EVENT: CONNECTING
2014-05-02 15:55:03 Tunnel Options:V4,dev-type tun,link-mtu 1560,tun-mtu 1500,proto TCPv4_CLIENT,comp-lzo,cipher AES-256-CBC,auth SHA1,keysize 256,key-method 2,tls-client
2014-05-02 15:55:03 Creds: Username/Password
2014-05-02 15:55:03 Peer Info:
IV_GUI_VER=net.openvpn.connect.ios 1.0.4-140
IV_VER=3.0
IV_PLAT=ios
IV_NCP=1
IV_LZO=1

2014-05-02 15:55:03 TCP recv EOF
2014-05-02 15:55:03 Transport Error: Transport error on 'mydomain: NETWORK_EOF_ERROR
2014-05-02 15:55:03 Client terminated, restarting in 2...
2014-05-02 15:55:05 EVENT: RECONNECTING
2014-05-02 15:55:05 LZO-ASYM init swap=0 asym=0
2014-05-02 15:55:05 EVENT: RESOLVE
2014-05-02 15:55:05 Contacting myIP:1194 via TCP
2014-05-02 15:55:05 EVENT: WAIT
2014-05-02 15:55:05 Connecting to mydomain:1194 (myIP) via TCPv4
2014-05-02 15:55:05 EVENT: CONNECTING
2014-05-02 15:55:06 Tunnel Options:V4,dev-type tun,link-mtu 1560,tun-mtu 1500,proto TCPv4_CLIENT,comp-lzo,cipher AES-256-CBC,auth SHA1,keysize 256,key-method 2,tls-client
2014-05-02 15:55:06 Creds: Username/Password
2014-05-02 15:55:06 Peer Info:
IV_GUI_VER=net.openvpn.connect.ios 1.0.4-140
IV_VER=3.0
IV_PLAT=ios
IV_NCP=1
IV_LZO=1

2014-05-02 15:55:06 TCP recv EOF
2014-05-02 15:55:06 Transport Error: Transport error on 'mydomain: NETWORK_EOF_ERROR
2014-05-02 15:55:06 Client terminated, restarting in 2...
2014-05-02 15:55:06 EVENT: CONNECTION_TIMEOUT [ERR]
2014-05-02 15:55:06 EVENT: DISCONNECTED
2014-05-02 15:55:06 Raw stats on disconnect:
BYTES_IN : 1872
BYTES_OUT : 3216
PACKETS_IN : 86
PACKETS_OUT : 72
NETWORK_EOF_ERROR : 24
CONNECTION_TIMEOUT : 1
N_RECONNECT : 23
2014-05-02 15:55:06 Performance stats on disconnect:
CPU usage (microseconds): 337140
Network bytes per CPU second: 15091
Tunnel bytes per CPU second: 0
2014-05-02 15:55:06 ----- OpenVPN Stop -----
2014-05-02 15:55:06 EVENT: DISCONNECT_PENDING

Version is 1.0.4.

Please have look at https://forums.openvpn.net/topic15760.html and https://forums.openvpn.net/topic15774.html for details.

Change History (3)

comment:1 Changed 4 years ago by Samuli Seppänen

Owner: set to jamesyonan
Status: newassigned

comment:2 Changed 15 months ago by Antonio

Owner: changed from jamesyonan to Antonio

Is this still a problem with recent versions of Connect? Note that Connect for iOS v1.2.6 has been just released. May you test that and re-open this bug if the problem still persists?

Thanks!

comment:3 Changed 15 months ago by Antonio

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.