Opened 6 years ago

Last modified 4 years ago

#384 assigned Bug / Defect

OpenVPN-GUI : password defaults to RTL (right-to-left)

Reported by: maayant Owned by: selvanair
Priority: major Milestone: release 2.3.14
Component: Windows GUI Version: OpenVPN 2.3.2 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: windows, gui
Cc: Heiko Hund

Description

Windows 7 Pro, SP1.
OpenVPN GUI v.5 (via openvpn-install-2.3.2-I003-x86_64.exe)

My Windows default language is English with Hebrew support.
When OpenVPN GUI asks for a password it defaults (or switch) to the
alternate language instead of staying in English.
This is extra annoying if you have a RTL language such as Hebrew or Arabic
installed on your system. It forces the user to switch back to English
every time s/he tries to connect.

Attachments (2)

ovpn_enterpass.png (9.1 KB) - added by maayant 6 years ago.
cp_input_lang.png (34.2 KB) - added by maayant 6 years ago.
Control Panel-Region and Language - Keyboards and Languages

Download all attachments as: .zip

Change History (18)

comment:1 Changed 6 years ago by Gert Döring

Milestone: release 2.3.4
Owner: set to Heiko Hund
Status: newassigned

Is this easy to fix?

comment:2 Changed 6 years ago by Heiko Hund

No idea. I've never had a such a combination.

Could you please elaborate what you mean by "it defaults (or switch) to the alternate language instead of staying in English". Does the input method switch from Hebrew to English? Do you know how to fix this even, maybe?

Changed 6 years ago by maayant

Attachment: ovpn_enterpass.png added

comment:3 Changed 6 years ago by maayant

Hi,

Please see attached "ovpn_enterpass.png" file.
As can be seen, the cursor is pointing to the left, meaning input language is now Hebrew. Requiring switching back to English every time I need to enter a password.

The input language should default to English or at least the "System Default" which is English in my case, see the cp_input_lang.png file for my language settings.

Changed 6 years ago by maayant

Attachment: cp_input_lang.png added

Control Panel-Region and Language - Keyboards and Languages

comment:4 Changed 6 years ago by Gert Döring

Milestone: release 2.3.4release 2.3.5

comment:5 Changed 6 years ago by armin

I have this problem too.

For find what happend just add a RTL language and click connect on OpenVPN-GUI and you see that Keyboard language changed.

I test with none RTL language and I don't have this kind of problem with theme.

I use version 2.3.4-I603 (as client) on windows 8.1 64bit.

comment:6 Changed 6 years ago by maayant

Hello,

Verified this bug still exist in openvpn-install-2.3.5-I601-x86_64.exe!

comment:7 in reply to:  6 ; Changed 6 years ago by aliv02022

Replying to maayant:

Hello,

Verified this bug still exist in openvpn-install-2.3.5-I601-x86_64.exe!

i were have the same problem, and found the solution!
change your setting on:

Control Panel > Language > Change date, time, or number formats (Left side) > Administrative > Language for non-Unicode programs > Change system locale... > change this to English (United States) > Restart!

if the problem where still exist set your input language to English and go to:

Control Panel > Language > Change date, time, or number formats (Left side) > Administrative > Welcome screen and new user accounts > Copy settings > tick two boxes below! click OK!

comment:8 in reply to:  7 ; Changed 6 years ago by maayant

Replying to aliv02022:

Replying to maayant:

Hello,

Verified this bug still exist in openvpn-install-2.3.5-I601-x86_64.exe!

i were have the same problem, and found the solution!
change your setting on:

Control Panel > Language > Change date, time, or number formats (Left side) > Administrative > Language for non-Unicode programs > Change system locale... > change this to English (United States) > Restart!

if the problem where still exist set your input language to English and go to:

Control Panel > Language > Change date, time, or number formats (Left side) > Administrative > Welcome screen and new user accounts > Copy settings > tick two boxes below! click OK!

Thanks.

This indeed bypass the problem, but we need this bug resolved as we have hundreds of OpenVPN clients around the world, we can't change the settings on all of them, we prefer sticking to older OpenVPN versions until this bug is fixed.

comment:9 in reply to:  8 Changed 6 years ago by aliv02022

Replying to maayant:

Replying to aliv02022:

Replying to maayant:

Hello,

Verified this bug still exist in openvpn-install-2.3.5-I601-x86_64.exe!

i were have the same problem, and found the solution!
change your setting on:

Control Panel > Language > Change date, time, or number formats (Left side) > Administrative > Language for non-Unicode programs > Change system locale... > change this to English (United States) > Restart!

if the problem where still exist set your input language to English and go to:

Control Panel > Language > Change date, time, or number formats (Left side) > Administrative > Welcome screen and new user accounts > Copy settings > tick two boxes below! click OK!

Thanks.

This indeed bypass the problem, but we need this bug resolved as we have hundreds of OpenVPN clients around the world, we can't change the settings on all of them, we prefer sticking to older OpenVPN versions until this bug is fixed.

you're right, the bug has to be fixed!

comment:10 Changed 5 years ago by Gert Döring

Milestone: release 2.3.5release 2.3.7

comment:11 Changed 5 years ago by Gert Döring

Milestone: release 2.3.7release 2.3.8

While we all agree this needs fixing, right now we do not have an active developer who can look at the GUI code and fix it. Bumping to 2.3.8.

(If someone looks and sends a patch, d12fk will surely integrate, but he said he's very very busy these days)

comment:12 Changed 5 years ago by Gert Döring

Milestone: release 2.3.8release 2.3.9

comment:13 Changed 4 years ago by Gert Döring

Keywords: windows gui added
Milestone: release 2.3.9release 2.3.11

nobody sent a patch yet...

comment:14 Changed 4 years ago by Samuli Seppänen

Milestone: release 2.3.11release 2.3.12

comment:15 Changed 4 years ago by Gert Döring

Cc: Heiko Hund added
Milestone: release 2.3.12release 2.3.14
Owner: changed from Heiko Hund to snair

old stuff, bumping milestone, and throwing over to @snair - maybe you have an idea how to test & tackle this

comment:16 Changed 4 years ago by Gert Döring

Owner: changed from snair to selvanair
Note: See TracTickets for help on using tickets.