Opened 6 years ago

Closed 19 months ago

#355 closed Bug / Defect (fixed)

OpenVPN Connect Crashes on Android 4.4.2

Reported by: rameous Owned by: jamesyonan
Priority: major Milestone:
Component: OpenVPN Connect Version: 1.1.12
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc: plaisthos

Description

When switching between mobile data and wireless networks or when the wireless network is toggled on and off multiple times it appears to cause a crash in the Android Kernel (see attached screenshot). This error condition has been validated on both a Nexus 4 and Nexus 7 device.

Error Message1: Problem creating TUN interface: Possibly the tun.ko kernel module is not loaded in your Android Kernel

Error Message2: Error creating the tun interface: cannot acquire tun interface socket

Attachments (1)

error.png (102.2 KB) - added by rameous 6 years ago.
Error Message Screen Shot

Download all attachments as: .zip

Change History (13)

Changed 6 years ago by rameous

Attachment: error.png added

Error Message Screen Shot

comment:1 Changed 6 years ago by Samuli Seppänen

Owner: set to jamesyonan
Status: newassigned
Version: 2.2.2

comment:2 Changed 6 years ago by Samuli Seppänen

Version: 1.1.12

I'm unable to reproduce this on a Nexus 7 running Android 4.4.2 and the stock kernel (3.1.10-g4776c68). Can you describe the exact steps needed to reproduce this issue?

comment:3 Changed 6 years ago by jcpetrucci

I'm experiencing the error also.

Model: Nexus 4
Version: 4.4.2
Kernel: 3.4.0-perf-g2cae413

Let me know if any other data would be helpful.

comment:4 Changed 6 years ago by Gert Döring

This is a bug in the Android implementation of the VPN API.

"OpenVPN for Android" also used to trigger this, but Arne added workaround, closing the tun and reopening it (possibly leaking packets in the meantime) as opposed to opening a new tun and then closing the previous one.

comment:6 Changed 6 years ago by plaisthos

Cc: plaisthos added

comment:7 Changed 6 years ago by djule5

I'm also getting this error with the same specs as jcpetrucci.

Model: Nexus 4
Version: 4.4.2
Kernel: 3.4.0-perf-g2cae413

This happens when I'm using a Private Tunnel profile. This error renders the whole VPN solution useless, because whenever you switch networks you lose the tunnel and need to restart the phone to make it work again.

As a side note, the Private Tunnel VPN app also disconnects when switching networks, but it seems that I can connect back manually after. However, having to enter my password every time it disconnects is very inconvenient, hence why I was trying to use the OpenVPN Connect app with a profile instead.

comment:8 in reply to:  2 Changed 6 years ago by mockturtl

Replying to samuli:

I'm unable to reproduce this on a Nexus 7 running Android 4.4.2 and the stock kernel (3.1.10-g4776c68). Can you describe the exact steps needed to reproduce this issue?

Same hardware and kernel here. I see the bug every few days, but I can't find steps to reproduce.

comment:9 Changed 5 years ago by Samuli Seppänen

I'm told that if "Seamless Tunnel" is disabled this should not happen. In OpenVPN Connect this can be found from the Preferences menu as discussed here.

comment:10 Changed 5 years ago by OrBy

I am still having this issue 100% of the time on my Asus Nexus 7 (2013) running KK4.4.4 3.4.0-g9-964c2.

I am able to connect and everything works as it should but then once I disconnect I am unable to reconnect.

My error says:

"Problem creating TUN interface - Possibly the tun.ko kernel module is not loaded in your Android kernel."

If I exit the application and go back in the log file also says: "TUN Error: cannot acquire tun interface socket"

Once I reboot I am able to connect again.

Battery saver will also cause the 1st error to pop up if the screen goes to sleep as I assume it's disconnecting and reconnecting as well.

I have a Motorola RAZR HD LTE running 4.1.2 that has the same .ovpn config file to the same server on it and it works 100% without any errors or issues (even battery saver) so it would seem like it's kernel or OS version specific.

If you need any more info, logs, or testing - please let me know as I would like to have this fixed.

comment:11 Changed 4 years ago by Samuli Seppänen

Does this problem persist on latest OpenVPN Connect and Android versions? If not, I will soon close this tickets as "fixed".

comment:12 Changed 19 months ago by Antonio

Resolution: fixed
Status: assignedclosed

waiting 3 years has probably been enough. closing the ticket.

Note: See TracTickets for help on using tickets.