Opened 6 years ago

Closed 15 months ago

#334 closed Bug / Defect (worksforme)

OpenVPN for iOS 1.0.1 ignores 'link-mtu' parameter in .ovpn config with tcp mode

Reported by: lawless96 Owned by: Antonio
Priority: major Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: iOS
Cc:

Description

Title says it.

Only works if the 'link-mtu' option is commented out on the server side. Essentially same client configuration works fine with normal OpenVPN on both ends of connection.

Server-side error:

WARNING: Bad encapsulated packet length from peer (1376), which must be > 0 and <= 1368 -- please ensure that --tun-mtu or --link-mtu is equal on both peers -- this condition could also indicate a possible active attack on the TCP link -- [Attemping restart...]

iOS log message:

Tunnel Options:V4,dev-type tun,link-mtu 1543,tun-mtu 1500,proto TCPv4_CLIENT,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client

Attachments (2)

FLM_geileis_ios.ovpn (129 bytes) - added by lawless96 6 years ago.
openvpn1.conf (557 bytes) - added by lawless96 6 years ago.
server config

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by lawless96

Attachment: FLM_geileis_ios.ovpn added

Changed 6 years ago by lawless96

Attachment: openvpn1.conf added

server config

comment:1 Changed 6 years ago by JoshC

Component: Generic / unclassifiedOpenVPN Connect

comment:2 Changed 5 years ago by Samuli Seppänen

Owner: set to jamesyonan
Status: newassigned
Version: 2.2.2

comment:3 Changed 5 years ago by Samuli Seppänen

Keywords: iOS added

comment:4 Changed 5 years ago by lawless96

Tested 1.0.4. Still a problem.

comment:5 Changed 4 years ago by amather

Same issue here. Tested 1.0.5. Still does not work.

comment:6 Changed 15 months ago by Antonio

Owner: changed from jamesyonan to Antonio

Version 1.2.6 is on the AppStore?. Could you please test that and re-open this ticket is the issue is still there?

Thanks!

comment:7 Changed 15 months ago by Antonio

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.