Opened 7 years ago

Closed 7 years ago

#289 closed Bug / Defect (duplicate)

ip address isn't set on TAP device / TAP device not coming up on Windows 8

Reported by: egroeper Owned by:
Priority: major Milestone:
Component: Networking Version: OpenVPN 2.3.1 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

As can be seen in this Forum-Thread several people seem to be affected by this.
Unfortunately there doesn't seem to be a bug report about the issue.

The problem:
Assignment of ip address to TAP device doesn't work / it's not up. At first glance it looks like the issue with a not started DHCP client service (same error message). But the DHCP client service is running.

Setting ip-win32 to netsh or ipapi doesn't help either.
Using netsh seems to make no difference.

Using ipapi results in:

ERROR: AddIPAddress a.b.c.d/255.255.255.0 failed on interface {153160CE-8F97-41D9-B327-8F9BC65CC980}, index=16, status=5010 (windows error: 'Das Objekt ist bereits vorhanden.  ') -- I am having trouble using the Windows 'IP helper API' to automatically set the IP address -- consider using other --ip-win32 methods (not 'ipapi')

And then works, on the second try:

Fri May 03 10:30:35 2013 TAP-WIN32 device [LAN-Verbindung] opened: \\.\Global\{153160CE-8F97-41D9-B327-8F9BC65CC980}.tap
Fri May 03 10:30:35 2013 TAP-Windows Driver Version 9.9 
Fri May 03 10:30:35 2013 Successful ARP Flush on interface [16] {153160CE-8F97-41D9-B327-8F9BC65CC980}
Fri May 03 10:30:35 2013 NOTE: You have selected (explicitly or by default) '--ip-win32 ipapi', which has a better chance of working correctly if the TAP-Windows TCP/IP properties are set to 'Obtain an IP address automatically'
Fri May 03 10:30:35 2013 Successfully deleted previously set dynamic IP/netmask: a.b.c.d/255.255.255.0
Fri May 03 10:30:35 2013 Succeeded in adding a temporary IP/netmask of a.b.c.d/255.255.255.0 to interface {153160CE-8F97-41D9-B327-8F9BC65CC980} using the Win32 IP Helper API
Fri May 03 10:30:40 2013 TEST ROUTES: 2/2 succeeded len=1 ret=1 a=0 u/d=up

But the first try always fails.

What helps is to explicitly enable the tap device:

netsh interface set interface "Local Area Connection" ENABLED

Or to simply open (you don't have to do anything there!) the Network Adapter Applet.
This has to be done only once after boot.

output not working tunnel (direct after boot):
02_not_working_tunnel_after_boot_ipconfig.txt
not_working_tunnel.log

output of working tunnel (after opening Network Adapter Applet):
04_working_tunnel_after_network_applet_ipconfig.txt
working_tunnel.log

Attachments (4)

02_not_working_tunnel_after_boot_ipconfig.txt (926 bytes) - added by egroeper 7 years ago.
04_working_tunnel_after_network_applet_ipconfig.txt (1.4 KB) - added by egroeper 7 years ago.
not_working_tunnel.log (13.2 KB) - added by egroeper 7 years ago.
working_tunnel.log (7.7 KB) - added by egroeper 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by egroeper

Changed 7 years ago by egroeper

Attachment: not_working_tunnel.log added

Changed 7 years ago by egroeper

Attachment: working_tunnel.log added

comment:1 Changed 7 years ago by egroeper

I just reproduced the issue with current OpenVPN 2.3.2 under my VirtualBox VM.

Not sure if this should be closed in favor of #316.

comment:2 Changed 7 years ago by Gert Döring

Resolution: duplicate
Status: newclosed

Since #316 is having more details in it, it makes sense to bundle Win8 connection issues there. Closing this one.

Note: See TracTickets for help on using tickets.