Opened 6 years ago

Closed 5 years ago

#278 closed Bug / Defect (fixed)

OpenVPN client fail to connect to server because of invalid temp path

Reported by: blackeagle Owned by:
Priority: critical Milestone:
Component: Generic / unclassified Version: OpenVPN 2.3.1 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: windows
Cc:

Description

The client fail the connection to the server because the local temporary path looks invalid.
The bug is seen on windows 8. I did not test on other OS.
The user's temporary folder is located into the following path:
C:\Users\_user_name_\AppData?\Local\Temp
If _user_name_ contains accented letters (Exemple: Fréderic), OpenVPN does not recognize the path.
I had to create a new user without accent to be able to connect.
No all user are able to change the username (In an company for instance).

Change History (5)

comment:1 Changed 6 years ago by MaxMuster

At least as a work around you might simply use the option --tmp-dir dir and provide another temporary directory.

comment:2 Changed 5 years ago by Samuli Seppänen

Keywords: windows added
Priority: blockercritical

Tested this on Ubuntu 13.04 and could not reproduce it using Finnish special characters (äöå).

I was able to reproduce this on on Windows 7 and OpenVPN 2.3.2 using the same characters (äöå).

comment:3 Changed 5 years ago by Samuli Seppänen

Asked about this on openvpn-devel mailing list. If this is a common problem we should fix this a.s.a.p. I don't think we can demand people to create new user accounts solely for OpenVPN use.

comment:4 Changed 5 years ago by Samuli Seppänen

After some more testing I noticed that I had not been able to reproduce this on Windows 7 Enterprise N after all. The issue I did reproduce was somewhat related - if you use any non-ASCII characters in the OpenVPN config file, you need to save the file using the UTF-8 character encoding, or you will not be able to connect. Some editors such as Notepad++ support saving text files as UTF-8.

In any case, d12fk provided a patch which apparently solves the issue the original reporter has. These installers contain the fix:

Please test if these solve the reported issue and report back.

Note that this issue is probably Windows 8 -specific, as it does not(?) mangle paths into the 8+3 compatibility format like Windows 7 and earlier do.

comment:5 Changed 5 years ago by Gert Döring

Resolution: fixed
Status: newclosed

Patch has been committed to master and release/2.3 tree, and we're reasonably sure it will fix this issue. So I'm closing the ticket now.

If it is not closed (please test samuli's build and report back!), just reopen.

commit 925b8a463b78620c1f856a0224396ac7d53e6295 (master)
commit 1146c724e4d966248d23a0b350bc76d1af35a00c (release/2.3)

Note: See TracTickets for help on using tickets.