Opened 12 years ago
Closed 12 years ago
#273 closed Bug / Defect ( fixed )
Switching on snappy compression from a config file fails
| Reported by: | Samuli Seppänen | Owned by: | Gert Döring |
|---|---|---|---|
| Priority: | major | Milestone: | |
| Component: | Generic / unclassified | Version: | OpenVPN git master branch (Community Ed) |
| Severity: | Not set (select this one, unless your'e a OpenVPN developer) | Keywords: | |
| Cc: |
Description
Adapted from James' description:
"There is still one issue that I haven't solved with
snappy patch
in 2.1. When running in server mode, the patch works fine if per-client-session compression parameters are set via client-connect script or management interface, however the patch fails if they are hardcoded into config file."
This ticket can be fixed after
porting of 2.1.x-only patches to master
has been finished.
Attachments (2)
Change History (5)
comment:1 Changed 12 years ago by
comment:2 Changed 12 years ago by
Actually, it's even worse - not only "switching on snappy from config file" fails but also "any compression" - I have "comp-lzo" set in my server config, and upon client connect it seems to fall down to "no compression"...
"compress <anything>" in ccd/client.conf works fine.
OTOH with the hints from James this should be fairly easy to spot now... just need to understand the flow of compression configuration through the code.
Changed 12 years ago by
| Attachment: | 273-patch.txt added |
|---|
patch seems trivial, maybe I'm overlooking something. mailed james, asked for review
Changed 12 years ago by
| Attachment: | 0005-Fix-usage-of-compression-.-from-global-config.patch added |
|---|
commited to git. will send to list tomorrow.
comment:3 Changed 12 years ago by
| Resolution: | → fixed |
|---|---|
| Status: | new → closed |
committed to master, as commit 1690f290f4bd2b203634e8fef9a82f7a03e5b06b
More info from James: