Opened 9 years ago

Closed 5 days ago

#253 closed Feature Wish (wontfix)

Let me opt-out of l18n

Reported by: Dirkjan Ochtman Owned by: Selva Nair
Priority: minor Milestone:
Component: Generic / unclassified Version: OpenVPN 2.3-beta / 2.3-RC (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

In #252, I get the error message in Dutch because the locale on my (64-bit Windows 7) system is set to Dutch. However, my language is set to en-US. I would much prefer OpenVPN doesn't try to match my locale or at least give me an option to opt out of it.

Change History (11)

comment:1 Changed 9 years ago by David Sommerseth

Owner: set to Heiko Hund
Status: newassigned

comment:2 Changed 9 years ago by Heiko Hund

Right click on the GUI tray icon. Go to "Settings… » General » User Interface" and select the language of your choice from there.

comment:3 Changed 9 years ago by Dirkjan Ochtman

Well, that doesn't work if I can't even start the GUI.

In particular, localized error messages suck a lot because they harm Googlability.

comment:4 Changed 9 years ago by Heiko Hund

I agree.

Additionally it puts more work on the translators because they have to do the error messages, which are hopefully mostly unseen, anyway.

In some future version the error reporting will be redone to present the actual error in English with some framing in the local language. Also automatic language selection will take the set display language into account.

comment:5 Changed 9 years ago by Dirkjan Ochtman

Awesome, thanks.

comment:6 Changed 9 years ago by Samuli Seppänen

Priority: majorminor

comment:7 Changed 8 years ago by Gert Döring

What version is our goal for this?

comment:8 Changed 8 years ago by Heiko Hund

Have not planned to work on this currently.

comment:9 Changed 4 years ago by alexwriter

[removed nonsense and spam]

Last edited 4 years ago by David Sommerseth (previous) (diff)

comment:10 Changed 4 years ago by David Sommerseth

Owner: changed from Heiko Hund to Selva Nair

comment:11 Changed 5 days ago by Selva Nair

Resolution: wontfix
Status: assignedclosed
Type: Bug / DefectFeature Wish

This looks outdated. If the GUI cannot start and throws a localized error, the language can be changed in the registry: HKCU\Software\OpenVPN-GUI\ui_language -- set it to 1033 (decimal) for English. Not very user friendly, but hard to do better if the GUI fails to start and the default language or the one user has set is not what they want.

Note: See TracTickets for help on using tickets.