Opened 9 years ago

Closed 8 years ago

#202 closed Bug / Defect (fixed)

easy-rsa/whichopensslcnf does not detect openssl 1.0.1 correctly

Reported by: Bevan Owned by: Eric Crist
Priority: minor Milestone:
Component: Generic / unclassified Version: OpenVPN 2.2.2 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: easy-rsa whichopensslcnf openssl
Cc:

Description

The script whichopensslcnf which is part of easy-rsa does some checks on the openssl version to determine which configuration file should be used.

The problem is that the regular expression
"1\.0\.(:digit:?:alnum:?)"
does match the version string 1.0.1, which is the current version of openssl.

The exact output of "openssl version" here on a current Arch Linux system is:
OpenSSL 1.0.1 14 Mar 2012

Changing the expression in the script to
"1\.0\.(:digit:?:alnum:??)"
should solve this issue.

Please tell me, if I can help with any further information.

Change History (3)

comment:2 Changed 8 years ago by David Sommerseth

Owner: set to Eric Crist
Status: newassigned

comment:3 Changed 8 years ago by Eric Crist

Resolution: fixed
Status: assignedclosed

It appears this optional flag in the regex for the alphanumeric character at the end is in the current version of easy-rsa, unless I'm missing something.

elif $OPENSSL version | grep -E "1\.0\.[[:digit:]][[:alnum:]]?" > /dev/null; then
Note: See TracTickets for help on using tickets.