Opened 9 years ago

Closed 7 years ago

#186 closed Bug / Defect (wontfix)

Bug in key generation script

Reported by: Muot Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: OpenVPN 2.2.1 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: easy-rsa
Cc:

Description

I tried to generate keys after a clean install of version 2.2.1 and got a failure. Below is the sequence of steps from command window on a Windows Server 2008 Standard Ed:

C:\Program Files\OpenVPN\easy-rsa\init-config

Modified vars.bat with the proper substitues

C:\Program Files\OpenVPN\easy-rsa\vars

C:\Program Files\OpenVPN\easy-rsa>build-ca.bat

WARNING: can't open config file: c:\openssl/ssl/openssl.cnf
Loading 'screen' into random state - done
Generating a 1024 bit RSA private key
...++++++
.......................++++++
unable to write 'random state'
writing new private key to 'keys\ca.key'
keys\ca.key: No such file or directory
3124:error:02001003:system library:fopen:No such process:.\crypto\bio\bss_file.c:398:fopen('keys\ca.key','wb')
3124:error:20074002:BIO routines:FILE_CTRL:system lib:.\crypto\bio\bss_file.c:400:

Change History (3)

comment:1 Changed 7 years ago by Samuli Seppänen

Can this be reproduced using latest easy-rsa? There have been several changes to it since 2.2.1.

comment:2 Changed 7 years ago by Samuli Seppänen

Keywords: easy-rsa added

comment:3 Changed 7 years ago by Samuli Seppänen

Resolution: wontfix
Status: newclosed

Closing the ticket. Will reopen of this problem can be reproduced on latest easy-rsa version.

Note: See TracTickets for help on using tickets.