Opened 10 years ago

Closed 9 years ago

#145 closed Bug / Defect (fixed)

pkcs11 support is missing in openvpn 2.2.0 for windows

Reported by: JJK Owned by: Samuli Seppänen
Priority: critical Milestone: release 2.2.2
Component: Certificates Version: OpenVPN 2.2.0 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc: samuli@…

Description

pkcs11 support is missing in the openvpn 2.2.0 installer for windows.

Attachments (1)

0001-Backported-pkcs11-related-parts-of-7a8d707237bb18-to.patch (2.2 KB) - added by Samuli Seppänen 9 years ago.
First stab at fixing #145

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by David Sommerseth

Cc: samuli@… added
Milestone: release 2.2.2
Owner: set to Samuli Seppänen
Priority: majorcritical
Status: newassigned

This thread have more information:
http://thread.gmane.org/gmane.network.openvpn.user/32383/focus=32394

Needs to be solved in 2.2.2.

comment:2 Changed 9 years ago by Samuli Seppänen

Status: assignedaccepted

comment:3 Changed 9 years ago by Samuli Seppänen

There's a forums post with additional information.

comment:4 Changed 9 years ago by Samuli Seppänen

Alternate builds with pkcs11 support are available here, courtesy of Alon.

comment:5 Changed 9 years ago by Samuli Seppänen

It seems that this issue should not exist in "master". The fix has now been backported to release/2.2 branch:

Please test the installer and let us know if it fixes the issue. The included OpenVPN binary was linked to pkcs11-helper 1.09 (included).

Patch again release/2.2 branch is attached below.

Changed 9 years ago by Samuli Seppänen

First stab at fixing #145

comment:6 Changed 9 years ago by Samuli Seppänen

This bug was probably caused by the Windows buildsystem change (domake-win -> python + vs2008): the new build system lacked a mechanism for compiling OpenVPN with pkcs11 support.

comment:7 Changed 9 years ago by Samuli Seppänen

There may be need for an additional non-critical patch: openvpn --version does not show that PKCS11 support is baked in, even though it is.

comment:8 Changed 9 years ago by David Sommerseth

Resolution: fixed
Status: acceptedclosed

Applied to release/2.2 branch.

commit 81ce1d45f88bec701fd477fa061acd0f0033fdf9
Author: samuli@openvpn.net <samuli@openvpn.net>
Date:   Wed Dec 14 10:36:22 2011 +0200

    Backported pkcs11-related parts of 7a8d707237bb18 to 2.2 branch
    
    Fixes https://community.openvpn.net/openvpn/ticket/145
    
    Trac: 145
    Signed-off-by: Samuli Seppänen <samuli@openvpn.net>
    Signed-off-by: David Sommerseth <davids@redhat.com>
Note: See TracTickets for help on using tickets.