#1380 closed Bug / Defect (notabug)

openvpn 2.5.0 configure script says OpenSSL version too old. But 1.1.1f is installed

Reported by: andrey-mz3 Owned by:
Priority: major Milestone: release 2.5
Component: Installation Version: OpenVPN 2.5.0 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: openssl installation
Cc:

Description

I'm using a fresh install of Ubuntu Server 20.04 focal.
I downloaded the tarball and ran the configure script.
At openssl it says: checking additionally if OpenSSL is available and version >= 1.0.2... configure: error: OpenSSL version too old.

After trying sudo apt install openssl i get:
openssl is already the newest version (1.1.1f-1ubuntu2.1).

What could be going wrong?
I can't find any instances of this issue being discussed online.

Change History (3)

comment:1 Changed 10 months ago by Selva Nair

You probably do not have the dev package for openssl installed. Try

sudo apt install libssl-dev

comment:2 Changed 10 months ago by andrey-mz3

Thanks, that worked! I forgot to try this.

comment:3 Changed 10 months ago by Selva Nair

Resolution: notabug
Status: newclosed
Note: See TracTickets for help on using tickets.