Opened 2 years ago

Closed 5 weeks ago

#1363 closed Bug / Defect (wontfix)

Android OpenVPN Connect + Local DNS lookups not working

Reported by: vpnreguser Owned by: OpenVPN Inc.
Priority: minor Milestone:
Component: OpenVPN Connect Version: OpenVPN Connect for Android
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Please refer to the Android OpenVPN Connect forum link for more details: https://forums.openvpn.net/viewtopic.php?f=33&t=30826

To summarize, after a server crashed I had to upgrade to a newer OpenVPN server. Because of increased security I also had to upgrade the client's configuration files as well. After getting a successful connection, I was unable to access any local systems by name. I am running a local DNS. I am able to access local system's by their respective ip address. After much trial and error (again see the link), I came across OpenVPN for Android. Since it accepts OVPN files, I thought I would give it a try. After importing the same OPVN client file as the one used on OpenVPN Connect, local DNS worked. I tried different programs as well as a dig app to retrieve different records and they all worked. This leads me to believe there may be a bug in the Android OpenVPN Connect. Thanks.

Change History (3)

comment:1 Changed 2 years ago by Gert Döring

Owner: changed from yuriy to denys
Status: newassigned

comment:2 Changed 21 months ago by Antonio Quartulli

Owner: changed from denys to OpenVPN Inc.

comment:3 Changed 5 weeks ago by Gert Döring

Resolution: wontfix
Status: assignedclosed

OpenVPN Inc does not want to receive any feedback for the "Connect"
OpenVPN clients via the community bug trackers (here and in GH issues).

Please resubmit - if still relevant - via https://support.openvpn.net/

Note: See TracTickets for help on using tickets.