Opened 9 years ago

Closed 5 years ago

#136 closed Bug / Defect (fixed)

Spike in Deferred Procedure calls after switching network connections in Windows 7, 64-bit

Reported by: clay_pigeon Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version: OpenVPN 2.2.0 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: windows suspend resume
Cc: Heiko Hund

Description

I have no tested this on other hardware, but it happens reliably on my hardware (HP 2710p w/Intel 8256MM wired and 4965AGN wireless network) running Windows 7 (64 bit). I did NOT experience this under Windows XP (same hardware).

To replicate
1) Connect to a VPN via Ethernet. Wireless networks can be available, but none should be "connected."
2) Sleep and disconnect wired Ethernet. Order in which you do this doesn't seem to matter.
3) Wake up computer in a place where Windows can automatically connect to a "pre-registered" wireless network. In my situation, I'm moving from a part of the building where my wireless isn't available (so I'm connecting via Ethernet) to a part of the building where wireless is available (so Windows can automatically connect).
4) Windows 7 wakes up and begins automatically reconnecting to your wireless. As the same time, OpenVPN begins automatically reconnecting to your VPN.
5) Deferred Procedure Calls spike, saturating the processor and bringing everything to a near standstill. Quitting OpenVPN doesn't fix the problem. Only a reboot seems to fix it.

The only way I can avoid this is to disconnect and quit OpenVPN before putting my computer to sleep and moving locations.

Change History (6)

comment:1 Changed 7 years ago by Samuli Seppänen

Keywords: windows suspend resume added

Is this reproducible on recent OpenVPN versions? Also, is anyone else having this issue?

comment:2 Changed 7 years ago by Gert Döring

Cc: Heiko Hund added

This looks like a duplicate of #87 - we wake up, send out a packet with (then) invalid source address, all hell breaks loose.

We should fix it :-) - but nonetheless with the current gui, it shouldn't happen anymore, as the gui disconnects the openvpn process before going to sleep. CC:ing d12fk as the resident windows expert...

comment:3 Changed 5 years ago by Samuli Seppänen

d12fk: can we close this? I already closed 87 because nobody has reproduced it on a recent OpenVPN version.

comment:4 Changed 5 years ago by Samuli Seppänen

Resolution: worksforme
Status: newclosed

Closing as fixed. Please reopen as necessary.

comment:5 Changed 5 years ago by Samuli Seppänen

Resolution: worksforme
Status: closedreopened

comment:6 Changed 5 years ago by Samuli Seppänen

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.