Opened 2 years ago

Last modified 2 years ago

#1350 new Bug / Defect

DNS resolving not working after connect iOS device to mac

Reported by: wil-info Owned by:
Priority: minor Milestone:
Component: Networking Version: OpenVPN Connect for MacOS
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: DNS, Mac, iOS, device
Cc:

Description

Hi,

I've been using OpenVPN for a while now. And at first I couldn't figure out what was going on. Sometimes some DNS adresses wouldn't resolve anymore. After narrowing down the problem with some scripts the following is happening:

When I connect to the VPN, some custom DNS entries will be added. These resolve just fine:
$ >nslookup intraportal
Server: 172....
Address: 172....

Name: intraportal...
Address: 172...

After connecting ANY iOS device to my mac, the following is happening:
$ >nslookup intraportal
Server: 192....
Address: 192...

server can't find intraportal: NXDOMAIN

I can't seem to figure out why my VPN-only DNS servers are not being used anymore. The VPN is still up, because open RDP sessions function fine.

Im usinng a MacBook? pro with OSX Catalina (10.15.7 (19H15)), with OpenVPN Version 3.2.0 (1426).

Change History (3)

comment:1 Changed 2 years ago by wil-info

Additional info: the resolve.conf file is cleared and being set to the old config.

comment:2 Changed 2 years ago by wil-info

Additional info: the resolve.conf file is cleared and being set to the old config.

comment:3 Changed 2 years ago by Gert Döring

I do not understand what you mean by "connect iOS device to your mac". Connect how? Inbound VPN? Or USB?

If this is about the commercial OpenVPN Connect clients, questions shouldn't be directed here, though. These have a commercial support service, and we (community) can only guess.

Note: See TracTickets for help on using tickets.