#1333 closed Bug / Defect (fixed-external)

Connection issue since iOS 14 upgrade

Reported by: flic Owned by: yuriy
Priority: major Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Before upgrading to iOS 14, OpenVPN was working fine like this:
-[VPN] indicator showing on upper left of iPhone
-Turning off screen would disconnect from server
-Turning on screen after a few minutes would reconnect with server
-Everything working fine as expected

Now, after upgrading to iOS 14, OpenVPN v3.2.1.(3429) (prior vs was doing same following thing) OpenVPN does not work and let internet traffic pass through although the [VPN] icon is showing and is connected to the server

I have to quickly Disconnect/Connect? in the app to make OpenVPN to work.

Again, although everything say OpenVPN is connected and running, it is not letting internet traffic passing through

Please, fix

Thanks

Change History (3)

comment:1 Changed 12 months ago by flic

forgot to update pfSense package so I did and re-exported the iOS config (and re-imported on my phone) still not working: [VPN] is lit, OpenVPN server shows client (my iphone) connected but no internet traffic, like getting mail: stuck on Checking for mail... etc

comment:2 Changed 11 months ago by Yuri Ponomarev

I had the same issue with my iPhone iOS (14.0.1) OpenVPN app (ver. 3.2.2.(3507)) util I found that the root cause of the issue is the following setting:

"Battery Saver"

Untick the battery saver and you iOS device will keep the VPN connection in an expected way.

Regards

Yuri

comment:3 Changed 10 months ago by Gert Döring

Component: NetworkingOpenVPN Connect
Owner: set to yuriy
Resolution: fixed-external
Status: newclosed

Closing this, since the iOS client is really out of scope here, and since a solution was already provided. Thanks, @yuriy.

Note: See TracTickets for help on using tickets.