Opened 9 months ago

Closed 9 months ago

#1315 closed Bug / Defect (notabug)

"--tls-crypt-v2-verify script.sh" does not allow command arguments

Reported by: tincantech Owned by: Steffan Karger
Priority: major Milestone:
Component: Generic / unclassified Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc: tincantech

Description

In my server config I would like to use --tls-crypt-v2-verify my-script.sh with command arguments, unfortunately, openvpn will not allow any arguments.

EG. In my server config:

  • tls-crypt-v2-verify myscript.sh works OK
  • tls-crypt-v2-verify myscript.sh -v does not work.

The error message given is:

Options error: Unrecognized option or missing or extra parameter(s) in server.conf:13: tls-crypt-v2-verify (2.6_git)

Change History (3)

comment:1 Changed 9 months ago by tincantech

Cc: tincantech added
Owner: set to Steffan Karger
Status: newassigned

comment:2 Changed 9 months ago by tincantech

Silly me, the correct syntax is:

tls-crypt-v2-verify "myscript.sh -v"

comment:3 Changed 9 months ago by tincantech

Resolution: notabug
Status: assignedclosed
Note: See TracTickets for help on using tickets.