Opened 3 months ago

Last modified 7 weeks ago

#1300 new Bug / Defect

Unable to connect to OpenVPN server on Window 10 when certificate authentication is on

Reported by: arienaibipinu Owned by: yuriy
Priority: major Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

It connects just fine on my Android 10 but I got an error when trying to connect on Windows 10. I should mention that I did import the certificates.

Errors logs:

⏎7/10/2020, 8:18:43 PM MbedTLSContext::epki_sign exception: ssl_external_pki: MbedTLS: could not obtain signature
⏎7/10/2020, 8:18:43 PM Client exception in transport_recv_excode: mbed TLS: SSL read error : RSA - Bad input parameters to function

Change History (3)

comment:1 Changed 3 months ago by Selva Nair

Is that log snippet from a server built with MbedTLS? Which version of client is used on Windows 10? The recent release (2.4.9) is built with OpenSSL 1.1.1f and it looks like not playing nice with an MbedTLS server. Anything useful in the client logs?

Last edited 3 months ago by Selva Nair (previous) (diff)

comment:2 Changed 3 months ago by arienaibipinu

I should mention that the connection works on Windows 10 when I switch my OpenVPN settings to password only (no certificate required).

I am using OpenVPN 3.1.3 (713)

The logs comes from the OpenVPN Connection application itself and I am afraid there's not much more to add.

Last edited 3 months ago by arienaibipinu (previous) (diff)

comment:3 Changed 7 weeks ago by Gert Döring

This is openvpn connect and should be addressed via openvpn, inc. support.

Note: See TracTickets for help on using tickets.