Opened 3 years ago

Closed 5 months ago

#1227 closed Feature Wish (wontfix)

iOS: OpenVPN Connect 3.0.3 ignoring "allow-pull-fqdn"

Reported by: bribri Owned by: OpenVPN Inc.
Priority: major Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: allow-pull-fqdn
Cc:

Description

I have a configuration with the following options:

allow-pull-fqdn
route hostname.domain 255.255.255.255 net_gateway

In other OpenVPN clients it correctly routes traffic to the IP address of hostname.domain through the system's pre-existing gateway. However in OpenVPN Connect it has no effect. There is no mention of it in OpenVPN Connect's logs nor any error message aside from the option itself being listed under OPTIONS:.

If I use an IP address in place of the hostname it works as expected.

I do see [allow-pull-fqdn] listed under UNUSED OPTIONS.

Change History (3)

comment:1 Changed 18 months ago by Gert Döring

Owner: changed from yuriy to denys
Status: newassigned

comment:2 Changed 14 months ago by Antonio Quartulli

Owner: changed from denys to OpenVPN Inc.

comment:3 Changed 5 months ago by David Sommerseth

Resolution: wontfix
Status: assignedclosed
Type: Bug / DefectFeature Wish

Closing this. An answer to the same question can be found here: https://github.com/OpenVPN/openvpn3/issues/195

Note: See TracTickets for help on using tickets.