#1212 closed Feature Wish (invalid)

Feature request - Import config from URL

Reported by: 23746938745628374527836 Owned by:
Priority: major Milestone:
Component: Generic / unclassified Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

I have difficulty opening OVPN files on my iDevices due to MDM restrictions that are in place.

Irrespective of the reason for my issue, I thought that a useful feature of the app would be to accept a URL and have the client download and import the configuration rather than relying upon another app to provide the file.

Also not had any success using openvpn:// prefix but possibly not using it correctly.

Change History (6)

comment:1 Changed 10 months ago by plaisthos

I think app opens all files that have the correct mime type. I am not sure what an openvpn:// url would do in this case.

comment:2 Changed 10 months ago by David Sommerseth

Resolution: wontfix
Status: newclosed

I'm sorry, but this seems to try to circumvent "due to MDM restrictions that are in place."

If you have a MDM managed device, you do accept and grant the MDM administrator more power of your device, regardless of how stupid you might feel the MDM policy is.

Most apps should be able to download profiles via URL already, but it might need a specific Content-Type (the mime-type which plaisthos mentioned) in the HTTP response. Unless the MDM policy forbids this.

Closing as wontfix.

comment:3 Changed 10 months ago by 23746938745628374527836

Resolution: wontfix
Status: closedreopened

The MDM restrictions are intended to prevent data leakage, not to prevent opening of OVPN files or establishing a VPN connection. But if you think that this qualifies for closing the bug then I guess that’s that. The iOS client isn’t open source is it?

I can and do actively use OpenVPN on managed devices (which I also own) however the only method for transferring configurations is via iTunes which eliminates a number of use cases.

I realise that other apps can download OVPN, that’s not the issue - the issue is that OpenVPN cannot. I can save to iCloud but cannot “Copy to OpenVPN”. Happy to share a screen recording if that helps to articulate the scenario.

Last edited 10 months ago by 23746938745628374527836 (previous) (diff)

comment:4 Changed 10 months ago by 23746938745628374527836

Sorry, I feel like I need to clarify. The "data leakage" in question is related to files that are downloaded to the device, not to network traffic. It essentially makes system apps such as Safari, Files, in addition to 3rd party browsers such as Chrome, etc managed apps so that all files located within the app container is treated as "MDM" data - therefore meaning that files cannot be transferred out of the trusted location.

Last edited 10 months ago by 23746938745628374527836 (previous) (diff)

comment:5 Changed 10 months ago by 23746938745628374527836

Double sorry - seems like this may have been an iOS bug. Having not tested with multiple versions of iOS until now, I can see that it's resolved in iOS 13b2.

Please go ahead and close.

Thanks!

comment:6 Changed 10 months ago by plaisthos

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.