Opened 16 months ago

Closed 3 weeks ago

#1193 closed Bug / Defect (fixed)

t_net.sh breaks Ubuntu buildslaves

Reported by: Samuli Seppänen Owned by: Antonio
Priority: major Milestone:
Component: Building / Compiling Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

t_net.sh introduced by commit c4d5bcd7c90abbab2378ac865e326933b0ff1e1c does not work properly on Ubuntu 14.04, 16.04 or 18.04:

make  check-TESTS
make[4]: Entering directory '/var/lib/buildbot/slaves/openvpn/build-ubuntu-1604-amd64-stable-master/build/tests'
./t_net.sh: 28: ./t_net.sh: typeset: not found
./t_net.sh: 29: ./t_net.sh: GET_STATE[0]=ip link show dev dummy0 | sed 's/^[0-9]\+: //': not found
./t_net.sh: 30: ./t_net.sh: GET_STATE[1]=ip addr show dev dummy0 | sed 's/^[0-9]\+: //': not found
./t_net.sh: 31: ./t_net.sh: GET_STATE[2]=ip route show dev dummy0: not found
./t_net.sh: 32: ./t_net.sh: GET_STATE[3]=ip -6 route show dev dummy0: not found
./t_net.sh: 143: ./t_net.sh: typeset: not found

FAIL: t_net.sh

The "typeset" command is a Bash builtin command. I suspect the problem is caused by /bin/sh pointing to /bin/dash instead of /bin/bash on Ubuntus:

$ ls -l /bin/sh
lrwxrwxrwx 1 root root 4 Jul 26  2018 /bin/sh -> dash

Would it be possible to make t_net.sh work without doing some local fiddling on the buildslaves themselves?

Change History (2)

comment:1 Changed 11 months ago by Gert Döring

Isn't that long fixed?

We have some timing/race issues in t_net, but the basic "must have bash bit" got fixed...

Close?

comment:2 Changed 3 weeks ago by Gert Döring

Resolution: fixed
Status: assignedclosed

This was fixed long ago, I think. And we no longer see t_net failures.

Note: See TracTickets for help on using tickets.