Opened 13 months ago

Closed 3 weeks ago

Last modified 3 weeks ago

#1171 closed Bug / Defect (fixed)

unable to register due to plus sign in the mail address

Reported by: fakeuser Owned by: Samuli Seppänen
Priority: major Milestone:
Component: Community services Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Unable to register.

https://community.openvpn.net/pwm/public/newuser

"Email Address has invalid characters"

My e-mail has a plus sign (.) in the localpart. It's fully RFC 5322 compliant, against modern addresses with a dot (.) in the localpart.

Change History (7)

comment:1 Changed 5 months ago by sergio

Any update here?

comment:2 Changed 3 weeks ago by Samuli Seppänen

Status: newaccepted

I believe this is now fixed. I was able to register with an email that was in "user+foobar@…" format. I also noticed that our own email provider did not let such emails through. But that is unrelated to this Pwm issue. I suppose Google or some other email providers are more relaxed/can handle "+" signs.

Would somebody care to test if registration now works ok?

comment:3 Changed 3 weeks ago by Pippin

This was the only account where I could not use the + sign.

Working here now,
Thanks.

comment:4 Changed 3 weeks ago by krzee king

I checked + and _ and -, the 3 chars i know were failing (tested yesterday). I confirm this is solved.

comment:5 Changed 3 weeks ago by krzee king

Resolution: fixed
Status: acceptedclosed

comment:6 Changed 3 weeks ago by sergio

I've updated my e-mail with plus sign, could you reply please to be sure that mail is delivered.

comment:7 Changed 3 weeks ago by sergio

I confirm, that mail is delivered, all works fine and this issue is solved, thank you!

Note: See TracTickets for help on using tickets.