Opened 2 years ago

Last modified 2 years ago

#1104 assigned Bug / Defect

iOS: WiFi Calling disconnects after going to sleep mode when OpenVPN is connected

Reported by: diyputahi Owned by: yuriy
Priority: major Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:


iPhone 6s Plus, iOS 11.4.1

Initial situation:

  • phone is in use (not locked)
  • WiFi? is enabled and associated
  • OpenVPN is connected
  • WiFi? Calling is connected

WiFi? Calling works and most of internet traffic goes through OpenVPN. This is expected.

Current behaviour:
When I lock my phone, WiFi? Calling gets disconnected, OpenVPN gets disconnected and device disassociates from a WiFi? network. This doesn't happen if, prior to locking, I disconnect OpenVPN.

Expected behaviour:
When I lock my phone, WiFi? Calling stays connected, OpenVPN gets disconnected and device keeps associated with a WiFi? network.

It usually takes longer to connect to WiFi? Calling when OpenVPN is connected than otherwise.

Is there a way to configure OpenVPN profile to improve this situation, so that WiFi? Calling stays enabled when phone is sleeping? Is there something that can be done in the OpenVPN Connect iOS app (settings?) to improve this?

Change History (4)

comment:1 Changed 2 years ago by diyputahi

Software version: OpenVPN Connect 3.0.1

comment:2 Changed 2 years ago by diyputahi

Possibly related to #1036 – the reason WiFi? Calling stops working is because WiFi? becomes disassociated.

comment:3 Changed 2 years ago by Antonio

Owner: changed from Antonio to yuriy
Status: newassigned

comment:4 Changed 2 years ago by diyputahi

It seems that disabling "Reconnect On Wakeup" fixes this and #1036. WiFi?? stays associated and WiFi?? Calling stays connected (if enabled in iOS Settings->Phone) when device goes to sleep. OpenVPN disconnects, but I guess that's expected for battery saving reasons.

Note: See TracTickets for help on using tickets.