Opened 23 months ago

Last modified 23 months ago

#1098 new Bug / Defect

IOS: Crash on startup after update to 3.0.0.

Reported by: ZoRaC Owned by: Antonio
Priority: major Milestone:
Component: OpenVPN Connect Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

After update, the app crashes on startup. If I reinstall the app I’m able to start it and re-import ovpn. On connect it fails: “Creds: UsernameEmpty/PasswordEmpty?” even when the connection is a cert-only connection. After closing the app, I’m unable to start it again (it crashes on startup).

Attachments (2)

OpenVPN-2018-08-29-191206.crash (55.0 KB) - added by ZoRaC 23 months ago.
OpenVPN-crashlog from iOS
OpenVPN-2018-08-29-191158.crash (52.0 KB) - added by ZoRaC 23 months ago.
Another OpenVPN-crashlog from iOS

Download all attachments as: .zip

Change History (9)

comment:1 Changed 23 months ago by ZoRaC

Log:
2018-05-30 07:05:23 ----- OpenVPN Start -----
OpenVPN core 3.2 ios arm64 64-bit PT_PROXY built on Aug 17 2018 09:49:39

2018-05-30 07:05:24 Frame=512/2048/512 mssfix-ctrl=1250

2018-05-30 07:05:24 UNUSED OPTIONS
0 [persist-tun]
1 [persist-key]
4 [tls-client]
7 [block-outside-dns]
8 [verify-x509-name] [<domain>] [name]

2018-05-30 07:05:24 EVENT: RESOLVE

2018-05-30 07:05:24 Contacting [<IP>]:1194/UDP via UDP

2018-05-30 07:05:24 EVENT: WAIT

2018-05-30 07:05:24 Connecting to [<domain>]:1194 (<IP>) via UDPv4

2018-05-30 07:05:24 EVENT: CONNECTING

2018-05-30 07:05:24 Tunnel Options:V4,dev-type tun,link-mtu 1557,tun-mtu 1500,proto UDPv4,keydir 1,cipher AES-256-CBC,auth SHA1,keysize 256,tls-auth,key-method 2,tls-client

2018-05-30 07:05:24 Creds: UsernameEmpty/PasswordEmpty?

2018-05-30 07:05:24 Peer Info:
IV_GUI_VER=net.openvpn.connect.ios 3.0.0-712
IV_VER=3.2
IV_PLAT=ios
IV_NCP=2
IV_TCPNL=1
IV_PROTO=2
IV_AUTO_SESS=1

comment:2 Changed 23 months ago by ZoRaC

ovpn-file (keys removed, obviusly):
persist-tun
persist-key
cipher AES-256-CBC
ncp-ciphers AES-256-CBC
auth SHA1
tls-client
client
remote <domain> 1194 udp
setenv opt block-outside-dns
lport 0
verify-x509-name "<domain>" name
remote-cert-tls server

<ca>





</ca>
<cert>



</cert>
<key>



</key>
<tls-auth>
#
# 2048 bit OpenVPN static key
#



</tls-auth>
key-direction 1

Changed 23 months ago by ZoRaC

OpenVPN-crashlog from iOS

Changed 23 months ago by ZoRaC

Another OpenVPN-crashlog from iOS

comment:3 Changed 23 months ago by ZoRaC

We are having the same issue on two phones - one iPhone 7 and one iPhone 8. Both on iOS 11.4.1.

comment:4 Changed 23 months ago by newi

I have the exact same issue on 3 iPhones running 11.4.1. VPN Server running on Ubiquiti Edgerouter.

Ref: https://forums.openvpn.net/viewtopic.php?f=36&t=26980

comment:5 Changed 23 months ago by ZoRaC

I had an "ø" in the state-definition of the certs (see #1088). Re-issued CA-, server- and client-certs (with no "ø" in them), but no change. Tried setting user-login only on the server (no client cert), no change.

Tried importing and connecting to a different serviceprovider, that worked.
So there is something about the connection I use (see ovpn-file from 4 days ago) or the server setting, but I can't see what it could be. I've tried numerous settings on the serverside, but no change.

comment:6 Changed 23 months ago by newi

The client update that just came out fixed my issue!

comment:7 Changed 23 months ago by ZoRaC

I can confirm that 3.0.1 solved it for me as well.

Note: See TracTickets for help on using tickets.