Opened 2 years ago

Closed 8 months ago

#1087 closed Bug / Defect (fixed)

opensolaris, tap mode, extra ipv6 routes do not work

Reported by: Gert Döring Owned by: Gert Döring
Priority: major Milestone:
Component: Generic / unclassified Version: OpenVPN 2.4.7 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

Not sure whether this never worked, it was never properly tested, or we broke it somewhen - but 2.4 + master call "route add" with metric 0 for gateway routes, which is working for tun(?!) but fails for tap. The same route without the "0" works.

Sun Aug 19 21:22:19 2018 add_route_ipv6(fd00:abcd:194::/48 -> fd00:abcd:194:4::1 metric -1) dev tap0
Sun Aug 19 21:22:19 2018 /usr/sbin/route add -inet6 fd00:abcd:194::/48 fd00:abcd:194:4::1 0
add net fd00:abcd:194::/48: gateway fd00:abcd:194:4::1: Network is unreachable

(I'm fairly sure this worked at some point, but I'm not going to bisect this today - t_client tests 4/4a nicely trigger this)

Change History (2)

comment:1 Changed 2 years ago by Gert Döring

seems this was broken "since ever" and I just commented out the failing ping6 target in my buildslave's t_client.rc (and forgot about it right away). Meh.

comment:2 Changed 8 months ago by Gert Döring

Resolution: fixed
Status: assignedclosed

Really getting old, it seems. Open a trac ticket on it, forget about it, rebuild the buildslave with OpenIndiana?, bump into the same issue, and then actually fix it :-)

commit 01b3a48c29df6dc4bade3d8fb7903346a3f77887 (master)
commit 0b2b25dfa3a19aba9c99e9a55a082fe85c4ccd59 (release/2.4)
Author: Gert Doering <gert@…>
Date: Wed Oct 9 11:52:00 2019 +0200

Fix IPv6 routes on tap interfaces on OpenSolaris/OpenIndiana?

Note: See TracTickets for help on using tickets.