Opened 3 years ago

Closed 3 years ago

#1000 closed Bug / Defect (notabug)

Cannot see iPhone certificate

Reported by: photojpl360 Owned by:
Priority: major Milestone:
Component: OpenVPN Connect Version: OpenVPN Connect for iOS v1.2.6
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: Certificate not in Keychain
Cc:

Description

I have the latest 1.2.6 OpenVPN on my iPhone.
The external certificate profile is transferred correctly into my iPhone by emailing a file .ovpn. I email the .p12 file for the certificate for my iPhone, I am able to install it on my iPhone. But in OpenVPN Connect when I try to select it I see the message: No certificates are present in the Keychain.
I tried the same process by renaming my iPhone certificate .ovpn12 and it still does not work.
When I chech in my iPhone settings for the iphone certificate I see that is installed. But it says in red: Not verified. Could that explain why OpenVPN doesn't see it? My system worked for over a year before the last 2 updates 1.2.5 and 1.2.6. What could be the problem?

Change History (1)

comment:1 Changed 3 years ago by Antonio

Component: Generic / unclassifiedOpenVPN Connect
Resolution: notabug
Status: newclosed

Please read this FAQ: https://docs.openvpn.net/faqs/faq-regarding-openvpn-connect-ios/#How_do_I_use_a_client_certificate_and_private_key_from_the_iOS_Keychain

especially when it mentions the new file extension to use for your PKCS#12 file.

If you still need help, please open a thread on the forum.

Thanks!

Note: See TracTickets for help on using tickets.