Changes between Version 1 and Version 2 of Ticket #962, comment 5


Ignore:
Timestamp:
12/17/21 22:43:43 (5 months ago)
Author:
box913
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #962, comment 5

    v1 v2  
    1 I landed here from a Google search. I was experiencing a similar issue, but as it turns out, it was not caused by openvpn. The problem was actually caused by systemd sandboxing. Specifically, the systemd `ProtectHome=true` setting in the /lib/systemd/system/openvpn@.service file. See the details on the `ProtectHome` setting in systemd.exec(5). I had a symlink in /etc/openvpn linking to a file in my /home directory. The solution is change the value of `ProtectHome` to "read-only", move the symlink, or don't use a symlink.
     1I landed here from a Google search. I was experiencing a similar issue, but as it turns out, it was not caused by openvpn. The problem was actually caused by systemd sandboxing. Specifically, the systemd `ProtectHome=true` setting in the /lib/systemd/system/openvpn@.service file. See the details on the `ProtectHome` setting in systemd.exec(5). I had a symlink in /etc/openvpn linking to a file in my /home directory. Some solutions are change the value of `ProtectHome` to "read-only", or move the symlink out of /home, or don't use a symlink.