Opened 5 years ago

Last modified 4 years ago

#635 reopened Bug / Defect

Password for file "openvpn.xdb" is missing

Reported by: martin kubiak Owned by:
Priority: minor Milestone:
Component: Documentation Version:
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords: missing password
Cc: eugenekay

Description

At this site:

the user

  • eugenekay

has stored the file

  • OpenVPN.xdb

The file is password-protected (as every *.xdb - file).

The password is not written down on the website. So the file can not be used.

I wanted to use the templates from the .xdb - file.

Change History (6)

comment:1 Changed 5 years ago by Gert Döring

Resolution: invalid
Status: newclosed

whatever XCA is, it is not something maintained by the OpenVPN community - so please open the bug there, not over here.

comment:2 Changed 5 years ago by martin kubiak

Resolution: invalid
Status: closedreopened

Please read again.

The Ticket belongs to the wiki-site I referred.

There is a file uploaded which contains demo-material. the file is password protected.

Update the wiki, please and write down the password.

Maybe get in contact with the user who has created the wiki-page -- I tried using her/him in CC.

XCA is a tool to create/organize certificates.

THIS ticket says nothing about any error in xca. I am sure! If there would one, I woud go there and open an issue there. Believe me, please.

comment:3 Changed 5 years ago by Pippin

I guess the Wiki should be editted to remove that.
The database file can be opened only in read only.
Or maybe put a link to this tutorial:
http://www.carbonwind.net/VPN/XCA_OpenVPN/XCA_OpenVPN.htm

comment:4 Changed 4 years ago by Steffan Karger

I don't use XCA, but the default password for the password-protected example keys is 'password'. Have you tried that?

Apart from that - if one of you knows what the wiki page should say (I don't), please just update the page :)

comment:5 Changed 4 years ago by martin kubiak

Hi syzzer,

I tried to open the *.xca(xdb)-file with "password" as the password. No success.

BUT (and here comes the solution for my issue ...):

I typed the ESC-key too often when the error message was there and then the computer told me that when I do not provide the right password, I can not use or export the private keys. No problem for me -- I just want to have access to the templates which are stores in the *.xca(xdb)-file. After clicking sometimes on "OK" the gui was opened and the templates were accessible! Thanks ...

May be somone who has write-permissions on the wiki-site

could add a hint like:

To use the templates stored in the file "OpenVPN.xdb" do the following:

  • download xca
  • open the xca(xdb)-file using xca
  • Do not enter a password when xca asks for it -- click "cancel" and see the error messages. Confirm them.
  • Find in the xca-gui in the tab "templates" 3 templates for ca, server and client - certificate generation

Thanks for your time!

MArtin

Version 0, edited 4 years ago by martin kubiak (next)

comment:6 Changed 4 years ago by Steffan Karger

Good to read that you've found a solution. This looks like very useful information. Yes, please update the wiki page yourself - that is more transparent than me updating it with your text. And (if possible, I don't know the permissions users have on their own ticket) just close the ticket once that's done.

Thanks for contributing :)

Note: See TracTickets for help on using tickets.