Opened 7 years ago

Closed 13 days ago

#369 closed Bug / Defect (fixed-external)

IPv6 info wrong/missing in scripts environment.

Reported by: kcodyjr Owned by: Gert Döring
Priority: minor Milestone:
Component: IPv6 Version: OpenVPN 2.3.2 (Community Ed)
Severity: Not set (select this one, unless your'e a OpenVPN developer) Keywords:
Cc:

Description

In net30 topology, the ipv4 shows up as:

ifconfig_local = the server tunnel address that pings
ifconfig_remote = the server tunnel address that doesn't (p2p peer)
ifconfig_pool_local_ip = the peer tunnel address that doesn't (p2p peer)
ifconfig_pool_remote_ip = the peer tunnel address that pings

IPv6 is missing the two pool_ variables making DDNS for dual stack impossible.

Attached patch adds the variables. No comment about how screwy the field names are.

Attachments (1)

openvpn-ipv6-env.patch (1.4 KB) - added by kcodyjr 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by kcodyjr

Attachment: openvpn-ipv6-env.patch added

comment:1 Changed 7 years ago by plaisthos

Comment on IRC, so they don't get lost:

12:56:29 <@plaisthos> kcodyjr: It would be better to submit the patch to #openvpn-devel
12:57:49 <@plaisthos> kcodyjr: and on quick look it seems you overlooked env_filter_match
12:59:28 -!- n00bSaibot [~NoobSaibo@24?-213-19-74.static.mrqt.mi.charter.com] has joined #openvpn
12:59:55 <@plaisthos> kcodyjr: And I am not sure what happens if there is no IPv6 configured
13:00:39 <@plaisthos> kcodyjr: also changes to the man page are missing

comment:2 Changed 6 years ago by stipa

This looks like a duplicate of #230 "IPV6 environment variables missing for client-connect"

comment:3 Changed 6 years ago by Samuli Seppänen

Owner: set to Gert Döring
Status: newassigned

comment:4 Changed 14 months ago by kyraa

No diff for you, spammer!

Version 1, edited 14 months ago by kyraa (previous) (next) (diff)

comment:5 Changed 13 days ago by Gert Döring

Resolution: fixed-external
Status: assignedclosed

This got fixed a few years ago... not referencing the tickets, so updating trac got overlooked. And indeed, it's a duplicate of #230 :-)

commit a8f8b9267183c3cfc065f344d61effe6c55c3da6
Author: Heiko Hund <​heiko.hund@…>
Date: Wed Nov 25 17:46:49 2015 +0100
put virtual IPv6 addresses into env

Add missing environment variables for IPv6 virtual addresses:

ifconfig_pool_local_ip6
ifconfig_pool_remote_ip6
ifconfig_pool_ip6_netbits
this is in 2.3.9 and 2.4 (and 2.5, of course)

Note: See TracTickets for help on using tickets.