Opened 12 years ago
Closed 10 years ago
#280 closed Bug / Defect ( wontfix )
Management command "kill IP:port" will fail for IPv6 addresses
| Reported by: | Samuli Seppänen | Owned by: | Gert Döring |
|---|---|---|---|
| Priority: | minor | Milestone: | |
| Component: | Management | Version: | OpenVPN git master branch (Community Ed) |
| Severity: | Not set (select this one, unless your'e a OpenVPN developer) | Keywords: | |
| Cc: |
Description
Currently killing clients based on their IPv6 address using the management interface fails:
kill 2001:608:3:814::1000:1194 >LOG:1365538844,D,MANAGEMENT: CMD 'kill 2001:608:3:814::1000:1194' ERROR: client at address 0.0.7.209:608 not found
Killing the clients based on their name (cn) works as expected. This seems to be what people typically use. Still, this should be fixed for consistency's sake.
This issues was found and reported by cron2 at #openvpn-devel.
Change History (2)
comment:1 Changed 11 years ago by
| Owner: | set to Gert Döring |
|---|---|
| Status: | new → assigned |
comment:2 Changed 10 years ago by
| Resolution: | → wontfix |
|---|---|
| Status: | assigned → closed |
I'm not sure if we actually want this.
There is the "kill-client" management command which will kill by client-id, independent of IPv4 or IPv6, ":" characters in the CN, etc. - take an integer, kill a client, done...
Client-ID can be discovered by asking "status 2".
So I'm closing this for now, as "wontfix". Reopen if someone comes up with a good use case why we need this, and "kill-client" cannot be used.