Opened 14 years ago
Closed 14 years ago
#140 closed Bug / Defect ( notabug )
OpenVPN 2.2 will only start if using port 1194 on Windows server
| Reported by: | totalimpact | Owned by: | |
|---|---|---|---|
| Priority: | major | Milestone: | release 2.2.0 |
| Component: | Generic / unclassified | Version: | OpenVPN 2.2.0 (Community Ed) |
| Severity: | Not set (select this one, unless your'e a OpenVPN developer) | Keywords: | |
| Cc: |
Description
I am running windows 2003 server, if I change the default port of 1194 to anything else, the service fails to start with the following error.
TCP/UDP: Socket bind failed on local address 192.168.11.20:1199: Permission denied (WSAEACCES)
Once it is using 1194, it starts fine.
This is not a bug. You most likely have another process running which uses TCP/UDP port 1199. The "Permission denied" error is Windows prohibiting OpenVPN to make use of that port.