Changes between Initial Version and Version 1 of Ticket #1216, comment 6


Ignore:
Timestamp:
10/21/20 22:41:28 (11 months ago)
Author:
becm
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #1216, comment 6

    initial v1  
    44
    55The issue linked by tincantech is relate to `PKCS#11` hardware tokens, the solution in **those** cases is to use an up-to-date `pkcs11-helper 1.26` (recent OpenVPN 2.5 Windows builds or debian ''bullseye'').
    6 On Windows there is also [https://de.wikipedia.org/wiki/Cryptography_API:_Next_Generation CNG] for this use case, new padding is [https://github.com/OpenVPN/openvpn/commit/ce1c1beef1eb9ea776e00861117f72c4a1a6f1f8 supported] with `OpenVPN 2.5`.
     6On Windows there is also [https://en.wikipedia.org/wiki/Cryptography_API:_Next_Generation CNG] for this use case, new padding is [https://github.com/OpenVPN/openvpn/commit/ce1c1beef1eb9ea776e00861117f72c4a1a6f1f8 supported] with `OpenVPN 2.5`.
    77
    88The ''management protocol'' is extended in `OpenVPN 2.5` to support the new padding type (**this issue**).