Changes between Initial Version and Version 1 of Ticket #1024, comment 9


Ignore:
Timestamp:
02/20/18 11:39:04 (2 years ago)
Author:
Antonio
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #1024, comment 9

    initial v1  
    11yeah, OpenSSL 1.1. uses PKCS#5 v2.0 by default. Can you try adding this argument to the command?
    22`-v1 PBE-SHA1-3DES`
     3
     4or, if you want to stick to PKCS#5v2.0, you can specify the following:
     5`-v2 aes-256-cbc -v2prf hmacWithSHA`
     6
     7
     8FYI, a fix for this issue has recently been merged in mbedTLS, therefore it should relatively soon land into OpenVPN Connect too.